SSL Certificate Issue After AWS Amplify

We’re currently have the SSL encryption mode set to Full (Strict) and has been using that for a couple of years. But, we recently had a few things changed and now some users are complaining that the website is showing as “Not Secure” and it’s refusing to connect to our backend server. The reason for one of those users is “Certificate Date Invalid”. Our certificate is valid and we tried automatically setting the user’s device’s date and time.

What we changed:

  1. Our frontend app is now hosted on AWS Amplify with its domain management. We are using Cloudflare for our main domain and we are registering the Amplify subdomains on it as well.
  2. Our Cloudflare app was downgraded from Pro to Free for sometime and then it’s back to Pro again.

**Important Notes: **

  • The issue is showing to only some users
  • These users are having different subdomains
  • This issue is only showing on Chrome browser (tried the latest version)

Could this be solved from our side?

Can you Share your Domain ?

I’m sorry I’m not authorized to do that :confused:

The issue is not showing for me or any of my colleagues, only some users across multiple subdomains.
I’m not convinced it’s from our side, but I’m not sure why the problem is happening at all.

Without providing a Domain we can’t troubleshoot and check it !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.