SSL certificate is not active

SSL certificate is not active, whenever I try to access it is not secure."

Hi @vinaykarmalkar72,

That certificate warning is coming straight from your server. Although your nameservers point to Cloudflare’s, either you have Cloudflare paused or you have your DNS record set to :grey:.

You should fix the certificate on your server so it works with HTTPS, then make sure your SSL/TLS mode is Full (strict) and then re-enable Cloudflare or proxy the record.

Shall I keep the cloud symbol grey or orange?

You should fix the certificate on your server while it’s :grey: and can then switch it to :orange:.

Can I share my DNS record over here, I am still not getting what you’re trying to say.

Your site is not currently proxied through Cloudflare so the SSL error you are getting is coming straight from your server/host. You need to fix that first before you can have a secure setup on Cloudflare.

You should talk to your host about enabling SSL if you’re not sure.

How to fix that , should I contact my domain site for this?

You should contact whoever is hosting your website or your developer.

Actually, I have connected my domain to groove funnels but they are not hosting it

If looks like you’ve now enabled Cloudflare and so are getting a 526 error because of the invalid certificate. Wherever you go to make changes to your site and where your DNS records at Cloudflare point to, is where you need to go.

You mean I need to go to groovepages?

If that’s who your site is built with, yes.

It is still saying invalid SSL certificate, and host error

I changed the SSL from full (strict) to full and now its working. Thanks for your help…

That has just made your site not secure as Cloudflare won’t validate the certificate.

1 Like

No, it says secure and the lock icon is also there you may check

I am aware that it looks like ti is secure. The part of the connection between the visitor and Cloudflare is properly encrypted. It is the connection between Cloudflare and the server that is not validating certificates.

1 Like

ok, but it says it requires a trusted CA or Cloudflare Origin CA certificate on the server

Yes, that’s what I suggested you sorted earlier:

1 Like

but I don’t know how to do that