SSL certificate is invalid

I use your SSL certificate. In the browser line, when you go to your personal site, the https connection is crossed out and red (see screenshot). What is the problem? Google Chrome writes: “There is not enough information to verify this certificate.”

Your website is not yet using Cloudflare. You will need to change your nameservers to point to Cloudflare and proxy requests through Cloudflare to your origin. Right now you have a Cloudflare origin certificate installed, that is trusted by Cloudflare for connections from Cloudflare to the origin, but we would advertise a different SSL certificate on our edge to users when they connect.

That edge certificate can’t be ordered until the nameserver change is made.

1 Like

Hello! What you need to do is to describe in detail what to prescribe in order to earn your certificate. I have Windows 10.

This is not related to your pc.

You need to contact you registrar (mostly your hosting provider) and tell them you want to change your nameservers to They have been sent out to you via email. Maybe you can do this on your own via their control panel

Once this is dome you can start using Cloudflare. And secure your website.

1 Like

I did everything that is written in the instructions (I changed the server’s dns on Cloudflare), but the ssl certificate still does not work. Wait until the dns servers are replaced?

You do not need to no anything on your server. You need to change the Name Servers on you domain registrar to the CF’s provided ones.

What is your domain?

1 Like In the personal cabinet Cloudflare these servers |
are indicated. Change to them?

Exactly, they are already active on your domain though.

You are under Cloudflare now. The certificate is active.

You have mixed content on you page, though, that is the reason you do not see the padlock in the browser.

What do I need to do. That there was a lock.

I know there is no padlock, the issue is mixed content. There is a file that is loaded via HTTP:

I clear the dns cache. A green lock appears. But after a while again red. What is the problem?

I cannot connect anymore to the site because TLS fails. You must have disabled Universal SSL…

How to do it? And what to choose?

In the Dashboard, under Crypto, what do you see under the first two blocks?

I disabled TLS 1.3. Turn it on again?

SSL - Full (strict)

You surely did not do only that, because nothing works now, while yesterday it did. You can turn it back on so that we try to see if it solves the issue. Would you mind posting a screenshot of that section of your dashboard?

It seems there is some issue with the certificate, you should probably contact support at support[@]

This topic was automatically closed after 14 days. New replies are no longer allowed.