SSL Certificate, DNS records

Hi all,

My website DNS record is using the incorrect Certificate for some reason.

So I recently started using an old website that was listed on my Cloudflare account. I created a certificate for the website and when I type in the name of a DNS record in the website it says my website is now using a certificate from a different website on a different account. When I only use the base website URL it is using the correct Certificate but when I use the record of the website it goes and uses the other website Certificate.

What is your domain?

Hi Cyb3r-Jak3,

The website domain is and when I open the DNS record (, it is using the certificate for a * domain.

I’m not sure if this is a Cloudflare issue. When I get a CNAME record for, and I don’t get any record for

1 Like


I checked for the record as well, it seemed on of my colleagues misspelled the domain in the A record. We have fixed it and the record now shows correctly on that DNS checker. I have also deleted the on my Cloudflare account to see if that might resolve the issue.

When checking I get a valid certificate for the website that is issued by GTS CA 1P5
On the certificate is still the same issue, it is issued by Cloudflare Inc.

Is there something I need to check specifically when creating the record or certificate on Cloudflare perhaps?

I see this certificate as an origin certificate. Those are only good between your origin and Cloudflare and require the DNS record to be :orange:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.