SSL certificate active but not working

hi, guys, I need your help in activating my SSL certificate. My domain is I had successfully generated my SSL certificate last week and it was working fine. Due to some reason I had shifted nameservers back to Godaddy for 2 days. I have followed the same steps and changed everything back to Cloudflare now. It’s showing active everywhere but the site is still showing not secure. Please help what could be the issue. How do I fix this?

Your domain redirects to HTTPS and has a valid certificate.

Hii thanks for the quick response. but it does show connection insecure from my end. I tried from both chrome and firefox. I even deleted cache. What could be the possible reasons for thisScreenshot (8)

Screenshot (9)

Can you click on Advanced and see if you can get a look at which certificate is being served? I’d guess you’re connecting directly to the origin server and it doesn’t have a proper certificate.

Which SSL/TLS setting are you using here? Is it Full (Strict)?

The SSL/TLS setting is kept at Full. The 3rd option.
I tried clicking the View certificate option on firefox ,dont know what to make of it. It shows and organization as Bitnami.
Can you help? Whats the issue here?



Hope this gives you some clue
The certificate is not trusted because it is self-signed.


It sounds like your device isn’t getting the correct IP address for your domain. You may need to flush your local DNS cache or use a different DNS resolver. It’s also possible you’ve misconfigured a local hosts file for your own website. These are all settings within your own device.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.