SSL Certficate not working after installing

Hello everyone, I’ve installed a SSL Certificate using the tutorial provided by Cloudflare, and it seems to be installed properly on cPanel.

When accessing my site, I get this error:
NET::ERR_CERT_AUTHORITY_INVALID

I’ve removed all other Certificates and tried so much I could do with limited knowledge on certificates, but nothing seems to be working. I’ve also disabled strict mode and turned on full mode but that doesn’t work either.

Does anyone know what’s going on?

Hi @solarityreaver,

Is this a Cloudflare Origin Certificate that you have installed on cPanel? If so, Full (strict) is the correct option to choose. Are your DNS records :orange: and is your site proxied through Cloudflare?

Are you able to share the domain name?

Hello, I’ve tried on Strict, on Full, and on Flexible. None work. I installed the correct Origin cert in the cPanel. It seems like it’s working now, but I’m still not sure why it didn’t work previously.

If you are still having issues, can you post the domain name?