SSL Cert :cert: not working


#1

Hey guys. I need help plz. I set up an ssl cert and it shows active but I am having problems. When I set it to flexible, the format of the website is all screwy. When I change it to full I get a 404 and when it’s hard full. I get 526. Any help is appreciated. It’s coptowned.com vs https://coptowned.com


#2

Hey there. I’ll see if I can help some.

Yes your site is indeed screwy at the moment, primarily due to mixed content requests, which your browser is likely blocking. This includes requests for CSS and JS resulting the current layout of your site. I haven’t checked around but the main page has over 60 requests that are blocked because of this.

I see you’re running Wordpress. Do you have the Cloudflare plugin installed in conjunction with this plugin? Additionally, do you have Automatic HTTPS Rewrites enabled? The setting is found on Cloudflare dashboard > Crypto tab at the bottom.


#3

I am unaware of this plugin. Let me look that up. I turned the auto https bc I didn’t want my users to see the broken site


#4

Here’s some additional info about the plugin and this specific issue: