SSL causing duplicate content



I’ve added cloudflare ssl and I’ve received a warning from moz about duplicate content. When I’ve checked into this I’ve noticed that even though typing in redirects to a search on shows http version as status code 200 instead of 301 which is what I would of expected.

My question is, is there some additional configuration I need to do to resolve this issue?

In cloudflare > crypto I have the following settings:

SSL: Full (strict)
Always use https: On
HSTS: Not configured
Authenticated Origin Pulls: Off
Require Modern TLS: Off
Opportunistic Encryption: Off
TLS 1.3: Enabled+ORTT
Automatic HTTPS Rewrites: On



It seems that the 200 ok code is for the page after redirection.!topic/webmasters/KVTup7NmAmI

The redirectoion is working correctly. Your server response is 301 sent back to the requester, the reqester instantly re-requests the URL in the preferred form and get as 200 OK. shows the actual 301 whereas mxtoolbox shows 200 OK.

closed #3

This topic was automatically closed after 14 days. New replies are no longer allowed.