SSL appears and then disappears

Hi I have now got my SSL up and running on my website:

Cloudflare says my account is active (i have done all the DNS stuff). Now Im wondering why my website although it redirects to https:// it still doesnt show as secure in my browser (chrome) it just flashes breifly and then goes back to the (i) logo “Your connection to this site is not fully secure”

can anyone help?

Apologies, it’s a typo error. The domain name is actually

Hi @user2542,

If the SSL :ssl: isn’t showing correctly, that is often a case of mixed content on your page. If some of the content that is loading is not HTTPS there will be problems. Please check out this KB article for some helpful tips:

How do I fix the SSL Mixed Content Error Message?

Mixed content errors mean that your website is being loaded over HTTPS but some of the resources are being loaded over HTTP. To fix this you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS.

For example, if you load your images with a full URL:

<img src="" />

You would want to change this to:

<img src="//" />

By removing the http:, the browser will use whichever protocol the visitor is already using. An alternative option would be to enable the Automatic HTTPS Rewrites feature that can potentially fix these errors for you automatically. Do be aware that resources loaded by JavaScript or CSS will not be automatically rewritten and mixed content warnings will still appear.

See this Community Tip for further details

This topic was automatically closed after 30 days. New replies are no longer allowed.