SSL and port forwarding

I’m working on an endpoint for an ASP.net app on our local Debian machine.

When connecting to port 80, the SSL cert serves just fine but when I change the port for dontnet the endpoint I get an error “This site can’t provide a secure connection.”

I’ve got an SSL cert from Cloudflare. I’m working the endpoint like this:
domain.com:8880/somevariables

I’ve got the SSLCertificateFile in both VirtualHost *:453 and *:8080…
ASP.net requires a proxy to port 5000 for the dotnet core…

When I connect locally (183.168.2.x:8880) I get Cloudflare cert.
But when I connect with the domain domain.com:8880/somevariables I get the error

I’ve about exhausted my leads on this one. Anybody got any good ideas?

Set your SSL security to Full or Full (strict) to provide a secure connection. Flexible basically blurts out your DNS data on an unencrypted server. You can do this by opening the SSL/TLS tab on your cloudflare dashboard

Thanks William.

I’ve changed that setting but still getting the “This site can’t provide a secure connection” error.

Just to clarify, I’ve tried both Full and Full strict… Seems like Full strict is what I need… But still get the error.

Ports 80 and 8080 aren’t SSL ports. Try 443 and 8443. Cloudflare isn’t going to try to connect to 8080 using SSL.

Thank you so much. That was the ticket.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.