SSL and cloudflare setup followed by website not showing some content

I set up Cloudflare today and from the time i set it up my site does not show my company’s logo and animation at the bottom. Are these related? and can this be resolved?

Before moving to Cloudflare, was your Website working over HTTPS connection with a valid SSL certificate? :thinking:

Kindly, before doing anything at Cloudfalre settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Check with your hosting provider / cPanel AutoSSL / ACME.sh / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Otherwise, it might be some mixed content errors or redirect loops, if so :thinking:

Nevertheless, maybe you have something cached in your Web browser or the “Rocket Loader” feature is in a conflict with something too, if so, you could try to disable it under the Speet → Optimization tab of CF dashboard.

Hey Fritex

Before moving to Cloudflare my website was not working over HTTPS and did not have a valid SSL vertificate.

I Paused Cloudflare as you suggested and my logo and missing graphic did come back however my website was not secure as a result.

Check attached to see the difference in the graphics at the bottom of my website (with Cloudflare disabled the graphic shows well and when enabled an error shows up)

when disabled it shows without an error

i selected the full SSL option not the full strict

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.