SSL and 521 Web server is down on Apache2

I have website on apache2 and added SSL in /etc/apache2/sites-available/myconfig.conf file. I changed in Cloudflare option to Full and get error 521 Web server is down. Whe n I change to Flexible it works.
image
On my server in Ubuntu I added every port from Cloudflare to ufw:
[email protected]:/etc/apache2/sites-available$ sudo ufw status
Status: active

To Action From


Apache ALLOW Anywhere
443/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
22/tcp ALLOW Anywhere
20,21,10000:10100/tcp ALLOW Anywhere
13/tcp ALLOW Anywhere
14/tcp ALLOW Anywhere
18/tcp ALLOW Anywhere
15/tcp ALLOW Anywhere
17/tcp ALLOW Anywhere
29/tcp ALLOW Anywhere
32/tcp ALLOW Anywhere
Apache (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)
22/tcp (v6) ALLOW Anywhere (v6)
20,21,10000:10100/tcp (v6) ALLOW Anywhere (v6)
13/tcp (v6) ALLOW Anywhere (v6)
14/tcp (v6) ALLOW Anywhere (v6)
18/tcp (v6) ALLOW Anywhere (v6)
15/tcp (v6) ALLOW Anywhere (v6)
17/tcp (v6) ALLOW Anywhere (v6)
29/tcp (v6) ALLOW Anywhere (v6)
32/tcp (v6) ALLOW Anywhere (v6)

It doesn’t work.

What are you using for an SSL/TLS certificate on your server?

I bought certificate in certum.pl

Try the Pause Cloudflare on Site option from the Overview page and give it five minutes to update. Then see if your server works with HTTPS. Once that works, you can un-pause Cloudflare and use Full (Strict) SSL mode.

1 Like

Ok, I have to check and will give the response

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.