Ssl active but still not working on my site

ssl

#1

Yesterday i created account on cloudflare through free purchase and after setting everything, today i saw that the universal ssl is showing active but still i am not able to load my site with https.

I don’t know what’s wrong is going on. But https is still not working.

My cpanel is showing that there is no ssl certificate installed. I am getting redirected to this page
https://gharstuff.com/cgi-sys/defaultwebpage.cgi

Please help me asap.
Thank you


#2

You probably have SSL set to Full, but it should be set to Flexible. Give that a try.


#3

First of all thanks for the reply.

What does it mean
And what are the difference between full and flexible


#4

Thank you so much its working now after changing it to flexible.


#5

Wait, it is working in google chrome but when i open it in uc browser then its not working.
I tried clearing cookies and cache but still not working


#6

It’s pretty close to all secure. There are a few mixed content errors where you’re trying to load an image using an HTTP scheme:
https://www.whynopadlock.com/results/f820aa30-99e4-4553-a14e-0d8dd718baaa

I don’t know what the uc browser is, but it will require its own troubleshooting. My first guess would be a DNS issue with that browser – trying HTTPS straight to the origin server.


#7

Should i change all the links from http to https through a WordPress Plugin "search and replace "


#8

That’s what I’ve done in the past. Just be careful with what you type in. Change “http://gharstuff” to “https://gharstuff” That should do it. But make a backup first.

p.s. Yes, I didn’t type in the .com part. That’s not going to make a difference in the search, as what I typed is enough to locate the http links you need to fix.