SSL active but not working


#1

Hi there - we have a main domain and whole bunch of subdomains using Cloudflare. SSL on almost everything is working except for one subdomain - canvas.airdev.co. The settings are identical to everyone else but it keeps serving it over http instead of https. Would appreciate any help


#2

That subdomain isn’t going through Cloudflare. Its DNS entry is probably set to :grey: instead of :orange:.


#3

thanks @sdayman, I was just experimenting with different settings to see if I could get it working. I set it back to go through Cloudflare but not seeing any difference.


#4

Ok, I’m seeing a 525 that indicates your server doesn’t have an SSL certificate for that subdomain. When you were bypassing Cloudflare, I think I neglected to test if that subdomain supported SSL.

If that’s the case, you can either:

  1. Add an SSL certificate (or wildcard certificate) to your server -or-
  2. Create a Page Rule for canvas.airdev.co/* and set SSL to Flexible.

#5

thanks @sdayman - it looks like I have a wildcard certificate added here? Or am I looking in the wrong place?


#6

That one’s fine. The problem is on your server. canvas doesn’t have an SSL certificate.


#7

Thanks @sdayman but I’m still struggling unfortunately. I went ahead and applied a certificate on our server but now getting an “SSL handshake failed” message.

These are the same settings we’re using on other subdomains (such as algo.airdev.co)


#8

Now it’s unreachable. What happens if you switch it back to :grey:?


#9

@sdayman - just switched, getting the same issue but not sure if it takes a bit of time to take effect


#10

Going to origin and it’s still not responding to HTTPS.


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.