SSL Active, but https give 522 (time out)

Ok i give up, anyway thanks for help Sandro :+1:


@sandro
cant write more that 14 post/day so i will edit this one:


hmm
i create origin certificate, replaced .crt and .key file and:
now i got cloudflare certificate on localhost:
(Windows does not have enough information to verify this certificate)
Imgur


You really just need to configure a valid certificate on your server. Right now you have a self-signed one and that wont validate. The easiest thing might be to simply get an Origin certificate from https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/origin

Something of that sort should work.

That is now okay. Origin certificates are not trusted by browsers, only Cloudflare.

Now, enable Cloudflare, make sure “Full strict” is selected, and you should be good to go.

1 Like

wow, i guess everything works now!
on whynopadlock.com all ok
on cloudflare - Full (strict)
i got my padlock! :smiley:

before, when i try, origin certificate give me 2 codes. one is .CRT and one is .KEY, and i though that 1st one is a .CSR (like on screenshoot) or .PEM file. Thats why everything dont want works for me, but when you write “get an Origin certificate” then i realised its a .CRT file: D

Thanks a lot @sandro ! Thanks for your patience <3

1 Like

This topic was automatically closed after 28 days. New replies are no longer allowed.