SSL Active, but https give 522 (time out)

Hello.

Your SSL/TLS encryption mode is Full (strict)
Status: Active

http: works
https: give 522 (time out)

i take a look into: Community Tip - Fixing Error 522: Connection timed out but dont rly know what to do

Appreciate any help

Your server wont be properly configured for SSL. Make sure it is and that includes a valid certificate on your server. You most likely have to talk to your host about this.

How to make sure?

What should i ask them?

They need to configure a proper SSL certificate on your server for your site.

Whats your domain?

Oh sorry i forgot to write adress

luis.cf
(free domain from freenom)

Alright, yes, it does seem as if your server is not configured for SSL at all. That is something your host needs to address.

What should i ask them?


I thought it cloudflare providing SSL

Please use the search. That topic has been discussed endlessly.

You need a certificate on your server. You can use a Cloudflare Origin certificate if you want.

Please forgive me my lack of knowleadge.
I use UniServer Zero XIV, right now i enabled SSL there (port 443 open, dont know if needed but its open)
I trying to follow documentation: (http://www.uniformserver.com/ZeroXI_documentation/apache_free_server_cert.html)
I generate server.csr., then:
cloudflare.com > SSL/TLS > Origin Server > Create Certyficate > I have my own private key and CSR > paste my generated “server.csr” text, yes? > I got text, key? (pem format)? so this code is .key file or .pem file and what to do now?

or i doing something wrong earlier?

or should i use “Let Cloudflare generate a private key and a CSR” and then i got 2 files: .pem and .key but what next? i read " support guide on managing Origin CA certificates." but cant figure out what to do.

Would you feel comfortable to share your server IP address here?

yes ofc. 176.241.73.69, should i run apache now with generated self-signed certificate? (i wanna use cloudflare certificate, or any)

Port 443 is currently not accessible, which brings us back to my initial response that you need to configure the server for SSL. That requires the certificate (which you seem to have already configured, havent you?) but also the overall network configuration.

In short, your server needs to return your site on HTTPS before you can enable Cloudflare. Make sure it does and it will work with Cloudflare too.

Opened, sorry, always when i turn off apache for any changes this port is closed

with self-signed certificate i got: NET::ERR_CERT_AUTHORITY_INVALID, i guess becouse it have to be signed by Authority

Now it is running, but the certificate still does not match. You need a valid certificate. Once that is there Cloudflare should work too.

Yeah, but how to do that?

cloudflare.com > SSL/TLS > Origin Server > Create Certyficate > I have my own private key and CSR > paste my generated “server.csr” text, yes? > I got text, key? (pem format)? so this code is .key file or .pem file.
Should i do this now?

Thats a question for StackExchange I am afraid.

i guess it return me HTTPS but with unsigned certificate (NET::ERR_CERT_AUTHORITY_INVALID)
yes?

https://www.whynopadlock.com/results/891e5463-c590-460c-85a1-55a9b07f1be2
everything ok and not working :frowning_face:

Pause Cloudflare for the time being and get your site first up and running with a valid certificate. Only then enable Cloudflare again.