SSL activation on WordPress for subdomain

Hello,

I have a Free SSL activated with Bluehost and I have pointed my name servers to cloudflare on a free plan. Now I added a sub-domain “lms.dasbogen.com” whose A records are added to DNS. Ideally cloudflare should have first level subdomain included in its SSL right? However I’m unable to activate the existing SSL on my WP site for subdomain, whereas it is activated on my domain.

I’m using free certificate from bluehost added via Really Simple SSL.

Any idea how can I have my subdomain secured with SSL too? Thanks a lot in advance!

Hi

What do you mean by this? Any error description or message?

Hi, your website is redirecting all requests to www.lms.dasbogen.com
Universal SSL doesn’t support third level subdomain, so that is probably the reason why it isn’t working.
You could try removing that redirect and see how it goes.

2 Likes

Hello,

okay any idea on how could I possibly fix the redirect? The redirect is since yesterday when I enforced a HSTS header and as of now I have commented it out.

HSTS won’t redirect to www. HSTS will only put the “S” at the end of HTTP and reload.

WordPress is doing it:

You can configure wp-config.php to use the non-www URL:
https://wordpress.org/support/article/changing-the-site-url/#changing-the-site-url

2 Likes

Hi,

Thank you so much. Worked perfectly. SSL is now enabled on both my domain & subdomain (level 1). Cheers!

1 Like