SSH web - ERR: "not a http service"

Hi there,

I am a first time poster here on Cloudflare forum, please let me know if I need to change anything or create a new thread for my issue.

I am experiencing the exact same issue setting up my friend’s Cloudflare Access. I looked over my configurations and the hostname have Access enabled. Access Policy is set to Allow. I setup my own SSH Web Rendering without any problem. I tried to compare my config with my friend’s config and they are similar. Everything else works like SSH tunnel, config.yml, CNAME is set up, and Short-lived certificate is set up too.

Do you know what is the cause for this error? Is it a caching issue (I cannot find anywhere else that would go wrong)? I know 502 is a server error but based on the cloudflared logs (exact same error as PO), it looks like we are accessing http://ssh.DOMAIN.com directly which is not my intention. Shouldn’t Cloudflare intercept that HTTP request and make a ssh request to the server? Because again, my ingress only stated the following,

ingress:

  • hostname: ssh.DOMAIN.com
    service: ssh://localhost:22
  • service: http_status:404

and none of them is HTTP protocol other than the fallback 404. This will make cloudflared throw localhost:22 is not a http service no questions there, but I am wondering how did that HTTP request get to cloudflared in the first place?

Please let me know if you have any idea on where the problem is.

Thank you