SSH & VNC browser rendering fails


Got it to work by disabling all security features that were present on the vnc server
image

VNC Server settings:
image

1 Like

Some progress but still broken, I’m finally able to get it somewhat past the protocol handshaking and it received the authentication methods, but it seems to just stop itself after trying to authenticate.

Oddly, I just tried an incognito window and it seems to show the password field perfectly fine. Perhaps cAcHiNg?

Yeah I believe that caching might be playing a role in here, let me know if that fixed it for you

Control-clicking the refresh button unfortunately didn’t help on either of the two. Still no relevant errors being logged, but I am seeing on the SSH renderer that an error boundary is getting triggered. I’ll relearn how to use React Devtools and try to figure out what error is being raised to the error boundary.

I don’t get an error boundary triggered error on the VNC client. To figure out the issue there I might open the devtools debugger to the line where it prints that it’s trying to authenticate and step until I see something broken.

Line of code that causes SSH renderer error:

image

The VNC renderer doesn’t seem to hit any errors and I can’t quite figure out a specific point where it fails and just exits.

I’m pretty sure I had the same error while setting up SSH rendering. I can’t recall exactly what fixed it, I think I just installed the short lived certificates on the remote machine and it just began to work some minutes later.

It was a trial and error process of trying different guides until something clicked and worked.

What’s weird is almost any other device can connect perfectly fine so I’m not sure if it’s a configuration issue. My other theory for why incognito works and normal windows don’t involves browser extensions. Before making the forum post I did try to disable my adblocker in case that was causing the issue but it didn’t make a difference. I’m sure there’s at least one other extension messing with it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.