SSH or TCP Service dosnt work

Hey,

I would like to address my Raspberry pi via the tunnel and also use ftp/sftp. I have already managed to establish a working https connection, but ssh/ftp/sftp/tcp does not work.

My config for ssh:
tunnel: test
credentials-file: ~/.cloudflared/***.json
ingress:
- hostname: ssh .domain.de
service: ssh://localhost:22
- service: http_status:404

I can ping the address, but when I try to connect with ssh, it takes a long time to load and I get a timeout.
Does anyone know what I’m doing wrong?
Thanks in advance

How are you connecting? Unless you are using browser rendered SSH you need to have cloudflared installed on the client and connect via that.

I connect to ssh via putty.
By installing Cloudflare do you mean the package via the repository or is there something else?

It is the same cloudflared that you installed on the server.
Here is the guide from the docs

Thanks, I didn’t know that you also have to do something on the client.

I followed the instruction for native terminal

When connecting, this error message comes up on the client:
2022-12-22T22:11:00Z ERR failed to connect to origin error=“websocket: bad handshake” originURL=https:// ssh.domain. de
websocket: bad handshake
kex_exchange_identification: Connection closed by remote host
Connection closed by UNKNOWN port 65535

Is it a problem if I run another service like https on the same tunnel?

Try the solutions under that error from this page: [Preformatted text](https://developers.cloudflare.com/cloudflare-one/faq/teams-troubleshooting/#i-see-a-websocket-bad-handshake-error)

Or try this:

The ssh connection works for me now, thanks for the help.

However, I would also like to use ftp or sftp or tcp and unfortunately that doesn’t work yet. I would like to comminate with my rasbperry pi via an application (duplicati) using sftp or ftp. I didn’t find much about ftp and setting up the service tcp on port 21 unfortunately doesn’t work either.