SSH Hostname won't work after connect DigitalOcean with Cloudflare

I was using accessing my droplet with a hostname before going into Cloudflare. After that I’m only able to use my ssh access using my droplet IP.

How can I solve this?

To ssh your need to use the IP. CloudFlare does not proxy port 22 on the free plan.
You would need Spectrum to do it with your host name.

1 Like

Use the IP address. It’s more reliable, and Cloudflare doesn’t proxy SSH. You also don’t want to add a :grey: DNS entry for it because it’s better to keep that IP address hidden.

2 Likes

Thank you for the quick respond. I have another question. Is there any way to force the Https in my subdomains? lately I have to place it manually. Example subdomain.example.* sent me to example.com. For me to get into my subdomain I have to type https://subdomain.example.com.

Any way to solve this?

In crypto tab enable Always Use HTTPS.

I did but still.

Which address doesn’t redirect to https?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.