SSH handshake failed

Hello,

I wanted to add a cloudflare ssl certificate to my domain cloud.deko.yt. So I installed a origin certificate for this, but now I get the Error 525. After I disable the proxy on cloudflare, I can connect to the website without any problems. Just without SSL.

How can I fix this?

Hi there,

Thank you for your question!

I don’t see any SSL certificates on your origin, and you are using Full SSL mode. If you change it to flexible, does it resolve the issue?

In our 525: SSL handshake failed guide we discuss that the reasons for 525 errors are:

  • No valid SSL certificate installed
  • Port 443 (or other custom secure port) is not open
  • No SNI support
  • The cipher suites accepted by Cloudflare does not match the cipher suites supported by the origin web server

Flexible mode allows Cloudflare to serve the SSL instead of the origin, which works if there are no certificates installed on your origin webserver.

Our article End-to-end HTTPS with Cloudflare - Part 3: SSL options – Cloudflare Help Center is a good resource if you need a description of the different SSL options at Cloudflare.

Please let me know if this resolves the issue.

  • Gabe
2 Likes