Sse tag removed from page source code

Hi,

We add the index.html the sse tag for our angular8 application, which build as ssr - production.

The tag is rendered on the index as:

    <body id="body">
      <!--sse-->
      <app id="app"></app>
      <!--/sse-->
    </body>

but for some reason, the sse tag is removed when I enable the Auto Minify option in cloudflare.

Is this a bug?
why the tag is removed?

Because minify will remove HTML comments, however on Cloudflare’s side server side excludes will still work.

How we can test this?

Test what?

https://support.cloudflare.com/hc/en-us/articles/200170036-What-does-Server-Side-Excludes-SSE-do- actually even addresses your question

Note: SSE only will work with HTML. If you have HTML minification enabled, you won’t see the SSE tags in your HTML source when it’s served through Cloudflare. SSE will still function in this case, as Cloudflare’s HTML minification and SSE functionality occur on-the-fly as the resource moves through our network to the visitor’s computer.

What you mean what? to test if CF and the tag is really hiding from suspicious visitors

That is different question and as the quoted paragraph already says, SSE will still work.

To test it, you will need an IP address which Cloudflare has accordingly flagged, but that is a very different subject from your original question.

Thx. I’ll post a different question.

Just check out the linked article.