SRV records not working at all

I have searched and cannot find an answer.
I am attempting to create some SRV records for Plex and other services for my domain name.
I have set them up in the DNS, I have the corresponding A records for the subdomains, I have the entire chain unproxied, and when I do a DIG or DNS lookup, the SRV records are nowhere to be found.
Why is this happening?
Here is a screenshot of my DNS configuration

For more context/information. All the A records resolve just fine. I can access each individual subdomain without issue. Email still works just fine as well. I am only having issues with SRV records at this point.
I don’t believe I have set the SRV record up incorrectly. But if I have, please correct me.

Screenshot from DIG looking for SRV record.

Note that with what you have, the SRV lookup should be for

Having said that, your entry doesn’t resolve even looked up correctly. I just created one with the same settings as yours and it works. Did you remove the record?


No, I have not removed the record. This is the problem I am running into. None of my SRV records seem to resolve.

I was able to figure everything out. The SRV records are in fact working. But me being still fairly new to using SRV records kept trying to get them to work through a web browser…(face palm).
After finally coming to the realization that a web browser won’t work and also properly looking up the SRV records, I now know the proper use and application of them.


I’m facing similar challenge and i’m fairly new too. i’m trying to access my apps through the browser because thats what my clients are also going to use. What was your realization and please share the knowledge on the proper use and application for them.

  1. Can you elaborate on the challenge you see?

  2. Perhaps share what kind of record(s) you have tried to create?

  3. And how exactly that you tried to test them?

Your mention of “browser”, … are you actually trying to steer HTTP traffic via SRV records?

If so, I believe that could be a time consuming attempt, as no browsers appear to use SRV records to steer HTTP traffic.

1 Like

With a bit of research, i was able to figure it out. I had a node app running on my VPS and wanted my users to enter a url not the IP address and port number i.e 192.x.x.x:3000

I thought creating an SRV record could point the url to the ip:port. i found out the i had to create a tunnel in other for it to work.