SRV Records issues

I’ve been trying to fix this for about 2 days now. I have a mc server that I run with my friends. I got a domain name from Freenom. I set the dns servers and it was all working. I setup the A record and the SRV record and it all worked. points to ipofserver:25574. But then about a week later, it stopped working, the srv record would not be applied. Instead of going to port 25574, it would go to 25565. When i’m trying to fix it, I would get unkown host errors. Now, it won’t even resolve to the server ip. Keep in mind, when joining with the server ip, it works just fine.

Hi @thesinofthetin,

Please check your records against Creating DNS Records in Cloudflare for a Minecraft Server. If you are still having issues, post the domain and a screenshot of the records you added.


I actually followed that guide to set it up.

What hostname are you trying to connect to in Minecraft? If it’s join. then you probably need to change the SRV name to include that, as in the subdomain section of the tutorial.

If you’re trying to connect with the root domain, I don’t see why that wouldn’t work, just make sure the A record is :grey:.

I am joining with the root domain. And all of the records are not under a proxy.
The error from Minecraft is unknown host. So it seems like it’s not resolving to the server IP. Here is me pinging it. I copied and pasted the domain name from cloudflare so no spelling mistake should occur

What is the domain?

My friends would be very mad if I leaked the domain. Can I pm it to you?

  • Make sure that the nameservers on your dashboard are the same as those that your domain resolves to.
  • Check that your domain is resolving, and any records you add are showing up somewhere like
  • Pause Cloudflare on the domain (overview app, bottom right). Then Cloudflare is no longer involved and it’s a general DNS/Minecraft issue.

When using the dns checker, it finds, but it doesn’t find

As it’s an SRV, make sure you’re selecting the right type and using the _minecraft._tcp.yourdomain.tld hostname shown in your dashboard.

We can’t really help you with this. It doesn’t seem like a Cloudflare related issue.

Well, guess I’m not using freenom anymore. Is there any other free domain name registars you know of?

I’m not sure what the issue is with Freenom, but no - you tend to get what you pay for with registrars.


I was able to fix it by changing my name servers to Cloudflare DNS servers.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.