SRV Record Problems


#1

So I have this domain, lets call it example com. Basically I want to make it so when I go to panel.example.com it goes to a letter IP with number port. I have tried setting up an SRV record to go to it but every time I went to it it just said there was an error or something. Here is what I kind of have: https://i.imgur.com/HDRnTYK.png Any ideas on what I need to do? Do I need an A record or something?


#2

I believe you must set the full host, including your domain. That host must be DNS resolvable obviously.


#3

I can go to the url when I put it in my web browser so I think it is. :slight_smile:
What do you mean by set the full host including my domain?


#4

I think it should look like

_sip._tcp.panel. SRV 1 1 55555 panel.domain.com

Ensure that panel.domain.com isn’t set to :orange:


#5

@MarkMeyer beat me to it, for your requirements:

_sip._tls.panel.domain.tld   299   IN   SRV  100 1 443 a.letter.address.domain.tld

#6

I don’t have anything else set for panel.domain.com… should I have an A record? The only reason I say this is because there is no cloud next to the info once I added the SRV record.


#7

I should really go to bed . :joy:

What i saw was: do i need an a record for _sip._tcp.panel.? and totally ignored the rest
In this case the anser would be yes. ^^


#8

I see a lot of exter options such as 299, IN, SRV, 100, 1, 433 in yours. Could you tell me what they mean?
My current setup: http://prntscr.com/ja5m59

Thanks SO MUCH for the help btw! :DDD


#9

299: TTL (Time to live)
IN: internet
SRV: “SRV” string
100: priority
1: weightning,
443:destination port


#10

What would the A record be since I have an address that contains letters…


#11

nvm I got a number ip but I am still confused. I setup an A record pointing to the IP and named it panel2 then I redirected my SRV to panel2.example.com… will this work?


#12

Well insert that on the DNS config page. If that address is under you domain (the one you need to point to) then you need an additional A/AAAA record to resolve that, otherwise it would be the provider’s DNS that resolves it.


#13

Sorry, I am a total noob and I thank you greatly for helping me this far but could you simply what you said a little? By simply I mean could you noob-ify this:
Well insert that on the DNS config page. If that address is under you domain (the one you need to point to)


#14

It’s difficult to simplify, but let me try! Gonna do step by step with the most info possible per step. Gonna use this nomenclature.

_service._proto.name. SRV priority weight port target.

// your options I believe are:
// service     sip
// proto       tcp
// name        panel
// priority    1
// weight      1
// port        55555
// target      ?
  1. Get what you need to add to the DNS config. I believe you have all the options already, check if what I believe they are is good.
  2. If target is an IP you need to configure an A record (AAAA if IPv6) like what you did with the panel2.example.com record, notice that it must be :grey: since Cloudflare does not accept traffic on port 55555 at the moment on plans < Enterprise.
  3. Insert the SRV record, just like you did before pointing to that A record, e.g. panel2.example.com

It will become a record like this:

_sip._tcp.panel. SRV 1 1 55555 panel2.example.com.

This should work, given that the IP to which panel2.example.com points accepts traffic at port 55555.


#15

The port is actually 40325 but that is besides the point.
When I go to https://panel2.example.com:40325/ it works but panel.example.com or any variable (http or https) it says the site cannot be reached… http://prntscr.com/ja776u
Sorry if i’m annoying or a noob but you’re so helpful!


#16

If you’re using a browser you need to do some HTTP redirects too…

  1. You need to have panel.example.com defined and with an orange cloud next to it so traffic goes via Cloudflare
  2. You need to define a page rule for panel.example.com which is set to redirect to https://panel2.example.com:40325/

Any other type of client or device which understands the SRV records will be fine, but web-browers won’t read them so if you need that, then a pagerule is the best solution.


#17

Pay attention to the fact that Cloudflare does not proxy traffic on port 40325.

If you need any other subdomains to go to the panel2 one do a redirect, but it will have to be done by a server because, as said previously Cloidflare won’t accept traffic on those ports. The only case CF will work with is if the other subdomains just need to see traffic on port 443 (HTTPS) from a browser. In that case a page rule should work fine.


#18

This topic was automatically closed after 14 days. New replies are no longer allowed.