SRV record not resolving

as the title says. its formatted: _minecraft._tcp.minecraft (target = hostname.xyz) and have port assigned. DDNS is working. domain resolves just fine and can connect to service manually through hostname.xyz:port, but cannot connect with minecraft.hostname.xyz. verified NS record resolves and reports dashboard NS’s are correctly assigned. the SRV worked for a couple months. then suddenly the last 2 days it hasn’t. i’ve changed nothing about my network configuration or DNS entries. pretty stumped

What is the real domain name and record you are trying to resolve?

apothicserver.xyz is A name for domain

minecraft.apothicserver.xyz is srv record

It seems to resolve ok…

dig +short _minecraft._tcp.minecraft.apothicserver.xyz srv
1 1 27004 apothicserver.xyz.

dig +short apothicserver.xyz
70.59.235.175

i didn’t figure there was anything wrong with the record. the thing that puzzles me is even though it resolves for you, i can’t connect to the server and when i check the SRV record on DNS checker nothing resolves.

interestingly though, i just tried getting onto the server via my wife’s computer and hers logged on fine. :confused:

okay i have a dumb question. i just did a windows security update cuz i got the pop up. now i can log in, but DNS checker still doesn’t resolve. i feel like i’m missing something here, but can updates being out of date like that prevent resolutions? i know you can configure things like that with popular reverse proxies, but i’ve clearly done no such thing for the minecraft server.

It too resolves fine…

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.