SRV record doesn't work anymore

So I have a domain xletron.tk. I have an “A” and “SRV” record for mc.xletron.tk pointing to port 25565, working perfectly fine. However, when I create another record map.xletron.tk (A and SRV port 25566), the A record points to my router on port 80! How do I know it’s port 80? I ran a webserver on port 80 and sure enough, it directed me to that. The SRV record (for map.xletron.tk) points to port 25566, so I’m not sure what to do.

Your question is not overly clear.

You have two A records (mc and map) which both point to the same IP address and are unproxied.

An A record does not point to any port to begin with, but only to an IP address. SRV records can contain port information but they also need other configuration details and need to be supported by the client in the first place.

What exactly is your question? Also, it probably is best if you post a screenshot of your DNS records.

1st A record: mc.xletron.tk (SRV configured port 25565)
2nd A record: map.xletron.tk (SRV configured port 25566)

the 1st A and SRV record works, points to the correct port.
for the 2nd A and SRV port, it points to the ip (A record works), but not port 25566 (SRV doesn’t work). When I do map.xletron.tk:25566, it works correctly.


(ignore youtube.xletron.tk)

The A records all resolve. But none of the SRV ones actually.

nslookup -type=srv _minecraft._tcp.xletron.tk sean.ns.cloudflare.com
Server:  sean.ns.cloudflare.com
Address:  108.162.193.231

*** sean.ns.cloudflare.com can't find _minecraft._tcp.xletron.tk: Non-existent domain

Are you sure you are configuring it on the right Cloudflare account? Can you verify the nameservers mentioned are sean and danica?

What you could also try is to delete these two SRV records and create them from scratch.

Yes, the nameservers are right.

In that case the question is if you have tried my suggestion.

The thing is - the SRV record for mc.xletron.tk works perfectly fine. I have tried deleting and creating again

It can’t, nothing is returned for that SRV record either. Also because they both have the same name.

There are two SRV records for _minecraft._tcp.mc.xletron.tk and _minecraft._tcp.map.xletron.tk but they are not even part of your screenshot.

Again, did you try my suggestion?

Also, where do these records come from if they are not part of your configuration?

I can comment on this. They are part of the screenshot, but the DNS UI for some weird reason that Support confirmed was by choice (@cloonan, can you maybe dig around a bit?) doesn’t show the full list of subdomains for SRV and only lists what you see ignoring the main subdomain at the end.

1 Like

Ohh, for effing sake :face_with_symbols_over_mouth:

True, the UI does omit in this case the whole hostname. That is not even a design choice but simply a UI bug. It should display _minecraft._tcp.mc in this case. Thanks for the clarification. :slight_smile:

So, @xletronyt, your records are properly in place

nslookup -type=srv _minecraft._tcp.map.xletron.tk sean.ns.cloudflare.com
Server:  sean.ns.cloudflare.com
Address:  108.162.193.231

_minecraft._tcp.map.xletron.tk  SRV service location:
	  priority       = 0
	  weight         = 0
	  port           = 8123
	  svr hostname   = map.xletron.tk
map.xletron.tk  internet address = 58.182.144.67




nslookup -type=srv _minecraft._tcp.mc.xletron.tk sean.ns.cloudflare.com
Server:  sean.ns.cloudflare.com
Address:  108.162.193.231

_minecraft._tcp.mc.xletron.tk   SRV service location:
	  priority       = 0
	  weight         = 0
	  port           = 25565
	  svr hostname   = mc.xletron.tk
mc.xletron.tk   internet address = 58.182.144.67

DNS wise that should be all right at this point. Also, the ports do accept connections, so that should be all fine.

1 Like

Tell that to support to which I mentioned it and was told it was that way by choice. The ticket was closed. I know it should display all, it’s insane it doesn’t…

Not in the mood for an argument with support :smile:. It probably was not even their decision but someone down the line thought he was being clever :roll_eyes:

1 Like

For sure, it wasn’t the support agent’s fault.

Well, he seemed to defend that choice :wink: but yeah, won’t have been his decision. Anyhow, the UI is - let’s put it nicely - messed up in this regard. The moment you open the record it shows the name, naturally, and the delete confirmation shows it too. Simply a bug which should be fixed.

1 Like

One thing that could be is that your client favours A records over SRV records, and as they have the same name it might never take the SRV records. That, however, is a question you need to clarify with Minecraft support. The DNS records are in place.

Maybe drop the names from your SRV records and set everything up on your naked domain instead. But again, that’s a question for Minecraft support :slight_smile:

1 Like

As far I know and from my own set-up the OP’s config should work. I only have the weight set to 5, but it may not matter. Probably needs to be not 0, though.

Considering they all have a weight of zero it shouldn’t be an issue

  A server selection mechanism.  The weight field specifies a
    relative weight for entries with the same priority. Larger
    weights SHOULD be given a proportionately higher probability of
    being selected. The range of this number is 0-65535.  This is a
    16 bit unsigned integer in network byte order.  Domain
    administrators SHOULD use Weight 0 when there isn't any server
    selection to do, to make the RR easier to read for humans (less
    noisy).  In the presence of records containing weights greater
    than 0, records with weight 0 should have a very small chance of
    being selected.
1 Like

It shouldn’t, but Minecraft may care… who knows.

That’s a Minecraft issue at this point however :slight_smile: