SPF record wont pass authentication

Im using mail-tester.com to verify why my emails are going to peoples spam boxes. It is saying my domain does not allow your server ********* to use your domain email.

I have gone into my dns settings on here and added the code to it but still not working. I even created a txt line with my cloudflare name server as my domain with no luck.

What can i do? this issues is also the cause of my DMARC failing check.

Cloudflare DNS will publish exactly what you put in the TXT record for SPF. I suggest you contact your mail host for assistance in configuring your SPF record to match your mail setup.

I purchased google workspace so that i can have my custom domain as my email. My domain is hosted by pagecloud. I purchased my domain from godaddy. lol this is crazy. Somehow cloudflare is the name server my website is using and it is showing that in godaddy. Which is why i came here and was forced to add my domain to register here just to get support and its only available in this community :frowning:

If your domain uses Gmail/Google for email, you should be able to get DNS instructions from them. Make sure you skim this entire page first before working on MX and TXT records:

So i never needed to register and sign up here to go into the DNS settings?

Ya what a big headache this turned out to be showing cloudflare as my name server who i never signed up with. I managed to knock out my website trying to do this. But after talking with google just now they did inform me all workspace emails are not authenticated until you go and manualy do it on their console. This should be common knowledge, we shouldnt have to spend so many hours online researching this stuff.
Well now i have to figure out how to get my site back up working after these changes. Waiting for everything to populate to see if it worked.
Hopefully cloudflare will offer phone or chat support in the future without having to register.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.