SPF record not showing up


#1

Hello, I have several SPF records for davison.com listed in cloud flare, and none of them are showing up on dig or kitterman.

[james:~]$ dig davison.com txt

; <<>> DiG 9.9.4-RedHat-9.9.4-14.el7_0.1 <<>> davison.com txt
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7407
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1500
;; QUESTION SECTION:
;davison.com. IN TXT

;; AUTHORITY SECTION:
davison.com. 3600 IN SOA elaine.ns.cloudflare.com. dns.cloudflare.com. 2025533114 10000 2400 604800 3600

[james:~]$ dig davison.com spf

; <<>> DiG 9.9.4-RedHat-9.9.4-14.el7_0.1 <<>> davison.com spf
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14223
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1500
;; QUESTION SECTION:
;davison.com. IN SPF

;; AUTHORITY SECTION:
davison.com. 3600 IN SOA elaine.ns.cloudflare.com. dns.cloudflare.com. 2025533114 10000 2400 604800 3600

;; Query time: 3 msec
;; SERVER: 69.20.0.164#53(69.20.0.164)
;; WHEN: Fri Aug 25 08:49:09 EDT 2017
;; MSG SIZE rcvd: 101


#2

they are showing up in dig now I had it missconfigured in cloudflare system


#3

Glad to hear that you solve your problem :smiley:

Please note, that per RFC 7208, the use of TXT RR record is mandatory for SPF record:

SPF records MUST be published as a DNS TXT (type 16) Resource Record (RR) [RFC1035] only. The character content of the record is encoded as [US-ASCII]. Use of alternative DNS RR types was supported in SPF’s experimental phase but has been discontinued.

While the use of SPF RR record is deprecated. I would highly suggest you to add a TXT record as well.


#4

Would it be okay to just switch the SPF to TXT ?
I don’t want extra clutter if it’s not needed.


#5

Sure, you can switch them with no problem since the use of TXT record is allowed since the beginning of SPF records (RFC 4408).


#8

Hey, For the past 5 days I have been facing the same issue. I added an SPF and default._domainkey records but neither are not showing up. I added them on several domains but they are not showing on any.

Here is what my SPF record look like:

DNS record type: TXT
Name: spf
Value: v=spf1 ip4:MY_IP ~all
TTL: Automatic

one of the domains with the above config: eatmeimfamous.com

am I doing something wrong? This issue is critical as several email providers like Gmail are flagging my emails as spam


#9

You domainkey is showing up. Can you post a screenshot of your dns settings. Blurr your IPs of you like.


#10

You should remove any record type SPF and just use record type TXT for your SPF records. SPF RR hasn’t been used for a number of years and was formally deprecated in 2014.

Confusing even being able to set them, don’t even know why Clouflare allow them any more.


#11

Thanks for your swift reply Marlk!

Kindly find attached my full DNS records for eatmeimfamous.com. Marked my IP in grey blocks.


#12

Hey saul, Thanks for your reply. I attached a screenshot of all my DNS records. I am not using DNS record of type SPF.


#13

Seeing as I’m here although I’m sure mark will chime in… your TXT record shouldn’t have name ‘spf’, it should use ‘@’ (with no quotes) to indicate your ‘root domain name’. when you save it, it’ll change in the interface to say ‘eatmeimfamous.com’ which is what you want.


#15

This is what I did wrong! I changed it just like you said and surprisingly it worked like a gem instantly. I can see the SPF record now and more importantly, email providers are no longer flagging my emails as spam.

by the way, is my DKIM1 record good as shown in the earlier-attached screenshot?

Thanks


#16

Yeah, the default._domainkey record looks good providing you copy and pasted OK. You can send an email from your account to one of the addresses on this site:

and it’ll mail you back with the results of their check and I’m pretty sure they check your DKIM signature as part of it.