SPF Issues

Hello everyone,

Got a bit of an interesting one for you all. I am having issues validating an SPF record, it is providing me errors when the syntax seems proper. The error provided when the record is created is “content must match the following: “/^v=spf/gi””. When I hit Create Record anyways, the record is created, however when I check with the SMPT company I’m using, the diagnostic tells me that an SPF record has not been created. The format for the policy is provided below.

v=spf1 a mx include:spf.kingmailer.org ~all

The MX record, the CNAME, everything else worked out fine. I’ve tried changing the syntax on the policy but nothing seems to work.

What’s the actual hostname (domain) of that TXT record?

postal-p4djhj._domainkey.habbo-defensedpt.com is the domain associated with it.

The domain itself does not have a TXT record for SPF. The “SPF” type of DNS record is deprecated, so get rid of the two “SPF” type records then add the TXT record you want.

Just got it, thank you!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.