“SPF” is not properly configured for this domain


I did a thing. I updated my entire website. Yes, I changed some of the paths. Now, none of my forms will work, which is the primary thrust of my business and website. I did have this problem two years ago and I cannot recall how I resolved the issue, but I do recall that I started here.

When I get into my email settings on cPanel this is the message that it gives me.

This system does not control DNS for the “dentrepairusa.com” domain. Contact the person responsible for the “zoe.ns.cloudflare.com” and “jim.ns.cloudflare.com” nameservers and request that they update the “SPF” record with the following:


v=spf1 +a +ip4: +include:spf.supercp.com ~all

That’s a TXT entry in DNS:

1 Like

Thank you for helping me. I got that piece of the puzzle solved, but it didn’t solve the “larger” problem that I was hoping it would.

The forms on my website no longer work

The previous path was

Literally no other setting were changed and its worked without fail for almost two years now. I wish I was as smart as you guys and understood this better. Ill dive in and soak up any suggestions that you might have. Happy New Years

What’s not working? The image upload says it didn’t work, and Console shows “XHR returned response code 500”, but it does let me go through the rest of the forms. I didn’t do the final step for contact information and “Finish.”

It also gives an error once you try to submit. It’s beyond my scope. I’ll tear it down and rebuild. If that doesn’t work, I’ll get with my host. Thanks for looking at it. Maybe they are blocking it somehow.

1 Like

Ive Isolated the Problem and found a workaround. Still About 5 hours to have a working product, but I want thank you guys for your aide. Especially, on new years. Have a profitable 2020, and a Happy New Year!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.