Spf and dkim records not functioning

I have added the spf and dkim records correctly according to my isp instructions, however when I try and send mail the smtp send comes back with this:

can anyone help please?

What’s the domain and post a screenshot of the DNS entries you configured.

nylanaseer co uk

The SPF entry is in place, as is the DKIM one

From a DNS point these two entries are configured. Best you contact whomever maintains the service where you got that message and clarify what they believe the issue is.

1 Like

thank you for verifying

You haven’t included Google in your SPF record, which is probably a problem if the error message tells you to follow Google’s guide to include them in your SPF record.

Also, google doesn’t use default._domainkey as their selector for DKIM, so you have likely not followed that tutorial either.

Hi, the error does not tell me to include Google in the SPF record but how would i do that?

I have followed the tutorial from my ISP to populate Cloudflare. Is Google’s different? I got the exact entries from my ISP.

You need to include the exact values as provided by the service you are using. You mentioned, this was provided by your ISP. Is your ISP handling any Google setup? If so, clarify it with them as already mentioned, otherwise reach out to Google, respectively whomever manages that, to clarify which values you exactly need.

As far as Cloudflare concerned, the configured values are in place and resolve fine. If you need some other values, you need to clarify this with the provider in question. Once you configure them on Cloudflare, it should work.

I don’t know what your exact email setup looks like, but the error message in your first post contains 2 links to Google SPF and DKIM tutorials.

Seeing that, I assume you’re trying to use Google to send/receive emails. I’m not sure how your ISP factors into things here. Is Google Workspace included in your internet package?

I thought it was a Google Workspace setup based on the initial screenshot, but the MX is using secureserver.net host, which is also in the SPF. That message may simply what Google includes in their SPF/DKIM errors. I have never seen one firsthand.

The message refers to Google but then the OP wrote the entries were provided by the ISP.

Whatever it is, either the ISP or any other provider needs to clarify that.

1 Like

Ah, I see, sorry for the confusion. I’m not using Google workspace. I’m trying to set up a wordpress smtp contact form mailing plugin. I’m now going through the google guide.

This is NOT solved - please ignore the solved thing!!!

Cloudflare cannot solve this as Cloudflare does not handle your email and cannot know or configure these entries. As already mentioned, you need to clarify this with the respective service provider and then configure the entries as instructed by them. As long as you do not have the correct entries, your mails might not be properly delivered but I am afraid that’s all beyond Cloudflare.

I would discuss this with the webhost or the ISP (if the ISP is involved here) and follow their instructions. Maybe you also need to contact your web developer for further details.

Thank you Sando and others. I’m talking to the ISP (I have developed the simple wordpress site so I am the developer).

1 Like

Then you need to make sure the SPF entry contains the necessary values and the DKIM entry the right signature of your email service.

Unfortunately, that would be really beyond the scope of the forum as that is not Cloudflare related but specific to your server/mail setup.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.