Spent 2 days trying to fix - sites offline and 525 error

So, I just downgraded from PRO to Free cloudflare service - and 2 of my sites go offline - coincidence? It seems many people with this issue either stop using cloudflare or move hosts…

Two of our sites just went offline (our sites with another host still work fine). Both sites that are offline have a cloudflare 525 handshake error. We made no changes to the sites or to CF, it’s been working for over a year fine. One site is: Olympicul dot com (CF is currently on - I can turn it off)

I talked to Godaddy and they reissued the SSL certificate (Let’s Encrypt ) - didn’t help. They spent a while looking and couldn’t find any server issues or SSL certificate issues. They could look at the site without CF it was loading fine - they said the issue is with CF.

So I paused cloudflare - used site called whynopadlock and it I found mixed content errors. I fixed pages and theme php insecure content, and added a plugin to force SSL (previously http did not redirect to https). I then passed the SSL certificate checker (mentioned above and SSLLabs which showed “A” results after fixing the mixed up content issues - no apparent issues.

So, with CF off, all pages were showing full https encryption - no issues with site operation, couldn’t find any errors with the SSL checks.

So I purged cloudflare cache - turned CF back on, full encryption (like it’s been set at) and the same issue happens - site goes offline and525 error.

Interestingly, when CF is ON - the SSL checker site mentioned above shows all is ok with the SSL certificate, it’s valid, website is forcing HTTPS, ssl matches domain, certificate is NOT expired. However with CF ON, it’s indicating there is a mixed (up) content issue: “The MixedContent tests failed. Please be sure that you can connect to your site over SSL and try again. Error Returned: Execution context was destroyed, most likely because of a navigation.”
I can’t find much help online as to what this means…

SO when CF is OFF - my SSL tests pass, but with CF on, I get mixedcontent issues and errors.

CF SETTINGS:
I am on full SSL/TLS, there is 1 active Edge Certificate, one backup, Always use HTTPS is on, minimum TLS changed to 1.1 (from 1.0 - this put up an error on an SSL checker), opportunistic encryption is on, TLS 1.3 is on, automatic https rewrites is on.

When I try Full Strict SSL/TLS - it doesn’t work - and flexible causes redirects.

I’ve tried the curl commands using the server IP address (per 525 Help articles), but server says “unknown”, even for the server IP. I’ve tried multiple variations of this, but I’m no server expert… it is a shared hosting platform.

I’ve also created a CF origin certificate and added to them with the other SSL certificates and that hasn’t helped either (did this with my other domain that has the same symptoms).

Hoping someone can help - as I’m just about ready to stop using cloudflare as our sites work fine without it.

WHAT ELSE SHOULD I TRY?
I’ve spent 2 days at this…
Thanks in advance for your help!

Yes


You have a number of issues and it will be difficult to troubleshoot them all at once. I’d pause cloudflare on the site, get the site working with ssl, unpause cloudflare and then set ssl/tls to full (strict)

Hi - Thank you for your reply!

I got all the SSL on site issues resolved yesterday as far as I could see. I had turned off cloudflare and the ssllabs and whynopadlock showed no obvious issues and the mixed content was fixed. So I turned back on the SSL/TLS, and the site stops working again.

Yesterday and today, when I turn on the full / strict SSL in cloudflare, it seems to work for a minute or so without errors, but then it reverts back to the site going offline with a 525 error. This is in a private browser and regular browser.

Do you have any other ideas?
Thank you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.