Spectrum app create fails with "requested protocol is not available" for port 22 via API

I’m attempting to create a Spectrum app via the API. However, this is not working:

curl -X POST "https-api-cloudflare-com/client/v4/zones/zzzzzzzzzzzzzzzzzzzzzzzzzzzzzz/spectrum/apps" \
     -H "X-Auth-Email:[email protected]" \
     -H "X-Auth-Key:zzzzzzzzzzzzzzzzzzzzzzzzzzzzzz" \
     -H "Content-Type: application/json" \
     --data '{"protocol":"tcp/22","dns":{"type":"CNAME","name":"testssh.zzzz.zzz"},"origin_direct":["tcp://"]}'

This curl command is pretty much straight out of sample code. Documentation shows a success response, but this is not working, instead it generates this response:

  "result": null,
  "success": false,
  "errors": [
    "code": 13002,
    "message": "The requested protocol is not available."
"messages": []

I first encountered the issue while trying to create an app for “udp/19132” (an alternate port for minecraft) and got this message. So I tried it using “tcp/22,” and get the same error.

Please advise.