Specific subdomain is not resolving in Minecraft, works fine otherwise

The subdomain I have set up for my Minecraft server suddenly stopped working a few days ago, and no longer resolves when attempting to connect in-game. The server is working fine, connecting with the IP address works. I set another subdomain on the same domain, pointing to the same IP as the subdomain that isn’t working, and this new subdomain works fine.

It seems that only this specific subdomain is not resolving, and only in Minecraft. Pinging the original subdomain works fine, and websites that list the server with areable to ping it and get the player count without problem.

I’ve tried removing and recreating the DNS record for subdomain, which didn’t work (I waited until I was able to ping the subdomain again, yet it still doesn’t work in Minecraft). I also made sure that proxying on the subdomain was disabled.

Kindly, consider looking at the below article for setup Mincertaft on a sub-domain:

Have you paid your game server?
Is there any Firewall running?
Have you updated Minecraft or changed something in the configuration file?
Is the IP address the same or different?
Is your domain active (or expired)?
Have you tried restarting the server?

1 Like

I know how to set up a subdomain for Minecraft, as I said in my initial post, this particular subdomain was working fine, for years. I made no changes to it prior to it not working.

The game server itself is still up, and setting up a different subdomain to the same IP works fine. There were no changes made to the domain/Cloudflare/server prior to this issue.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.