Specific API route stopped working

Hi,
I have Nuxt 3 site in SPA mode with server functions used. (So wrangler part compiled to the worker.)

All worked well several days but yesterday one specific API endpoint is not responding (loading infinitely). When watching functions logs I see other endpoints logs, but not this one.

That one endpoint is different compared to others - long running batch task calling itself.

export default defineEventHandler(async handler => {
  let { page } = getQuery(handler)
  if (typeof page !== 'string') page = '1'

  await processProductsPage(parseInt(page), handler.context.cloudflare?.env.CF_PAGES_URL ?? 'http://localhost:3020')
  return true
})

async function processProductsPage(page: number, baseUrl: string) {
  const { products, paginator } = await eshop<any>(`/api/products?include=images&page=${page}`)

  await Promise.all(
    ...
  )

  if (paginator.page < paginator.pageCount) {
    await $fetch(`${baseUrl}/api/pull-products?page=${++page}`)
  }
}

When it worked well I saw all subrequests in the log. Also on localhost it still work well.

I changed nothing last few days, still the same deployment on the Cloudflare Pages.