Sowetogospelchoir.com - Cloudflare


#1

This isn’t the first time this has happened and everytime it happens, I get the standard “it’s not us” from cloudflare but I am pretty sure, after numerous issues and loads of testing that the issue resides are cloudflare.

  1. I changed my website from http to https
  2. I get Chrome error: “ERR TOO MANY REDIRECTS”
  3. I grey cloud the site in cloudflare
  4. after 1-2 minutes the site works as expected
  5. Go back to cloudflare and clear the cache
  6. Turn cloudflare back on and wait 1-2 minutes
  7. I get a page that is all over the place (css is loading non-https resources and they are not showing page properly)
  8. wait 5-10 minutes and I start getting Chrome error: “ERR TOO MANY REDIRECTS”
  9. Grey cloud cloudflare again and everything starts working as expected.
  10. Leave it grey clouded over the weekend (72 hours)
  11. Log back in - clear cached, reactivate cloudflare - wait 5 minutes and - All resources change from being loaded over https and go back to http

Now, I am not sure how this could happen given:

  1. Cache should be clear
  2. Actual site is loading resources over https
  3. Actual site has not caching active

This is an ongoing issue that seems to never get resolved…

1. Request URL:

https://www.sowetogospelchoir.com/

  2. Request Method:

GET

  3. Status Code:

301

  4. Remote Address:

104.28.11.204:443

  5. Referrer Policy:

no-referrer-when-downgrade

1. Response Headers

  1. cache-control:

no-cache, must-revalidate, max-age=0

  2. cf-ray:

46d7a1249bc8a52a-NRT

  3. content-type:

text/html; charset=UTF-8

  4. date:

Sun, 21 Oct 2018 23:51:00 GMT

  5. expect-ct:

max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"

  6. expires:

Wed, 11 Jan 1984 05:00:00 GMT

  7. location:

https://www.sowetogospelchoir.com/

  8. referrer-policy:

  9. server:

cloudflare

  10. status:

301

  11. vary:

Accept-Encoding

  12. x-content-type-options:

nosniff

  13. x-powered-by:

PHP/7.0.32

  14. x-xss-protection:

1; mode=block

2. Request Headers

  1. :authority:

www.sowetogospelchoir.com

  2. :method:

GET

  3. :path:

/

  4. :scheme:

https

  5. accept:

text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8

  6. accept-encoding:

gzip, deflate, br

  7. accept-language:

en-GB,en-US;q=0.9,en;q=0.8

  8. cache-control:

no-cache

  9. cookie:

__cfduid=d4762803d2a4094a722c52e4b1092db4d1539913190; __utmz=74433424.1539913161.1.1.utmcsr=google|utmccn=(organic)|utmcmd=organic|utmctr=(not%20provided); wp-settings-1=libraryContent%3Dbrowse%26editor%3Dhtml%26post_dfw%3Doff%26posts_list_mode%3Dlist%26urlbutton%3Dcustom%26imgsize%3Dlarge; wp-settings-time-1=1539923083; __utma=74433424.1043432864.1539913161.1539927324.1540164641.4; __utmc=74433424; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_f30db532122b0388d48aecf0eeb267d5=millmaineMelb%7C1540337526%7CXCGbhA5GgQEJ5LcnLLZWztT4JUryVNKqvleb529AKAQ%7C4d34ad49bff9a12f6d4b25da4e66972bc8bee7768aea5005a19f738a225d5bc5; wfwaf-authcookie-30ba33427320dbab64be67d24f4289a5=1%7Cadministrator%7Caaca8e2d8c16a7524770c55df49f2f367e0a02367480d3aab0b5f7fd10d665be; __utmt_UA-45954107-1=1; __utmb=74433424.13.10.1540164641

  10. pragma:

no-cache

  11. upgrade-insecure-requests:

1

  12. user-agent:

Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

#2

In the “Crypto” tab, try turning “SSL” to “Full” or “Full Strict”.