"Sorry, you have been blocked" Firewall is off but still blocking WordPress comments


#1

I’m having a recurring issue where Cloudflare is blocking my users from posting WordPress comments.

Below is a comment that was blocked.

You seem to have a strange setup. Why are you using port 8000? And your document root should be /var/www/html, not /home/user/

Does 192.168.1.100:8000/info.php work?

My blog is about web development and people need to be able to post code examples.

Firewall is set to “Essentially Off” yet comments are still blocked. What can I do?


#2

You could try a page rule to disable WAF completely for that URL, on a paid plan you could also disable that specific rule I believe.


#3

I have tried disabling the firewall globally (“Essentially off”) and also setting a page rule for /wp-comments-post.php and I’m still getting this error when posting comments.

I have narrowed it down to /var/www/ - Cloudflare is blocking that. Very annoying as my blog specialises in Linux configuration and people need to post /var/www/ and other Linux directory paths.

Do I have to go with a paid plan just to get around this?

Thanks


#4

One thing to be aware of, it may take some time (15+ minutes) for users who are already blocked to get unblocked due to updated rules.

This is easy to reproduce when you restrict specific IPs, but I’ve seen it apply when Security Level is dropped (and only to users who already tripped something, and only for about 15 minutes)

tl;dr: Try again now.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.