Sorry, you have been blocked error

I’ve done this method with every domain I own, so tbh I don’t know why this specific domain is causing me trouble.

Steps I took:

  1. Purchased the domain directly from Cloudflare
  2. Made a tunnel from Cloudflare to my NAS
  3. Configured the public hostnames that I want to my local containers.
  4. And that should be it. I know this method works, because it worked with 6 of the domain names I own from Cloudflare, so I don’t understand why this one doesn’t work.

I did purchase “domain1” month ago though and had it set to access my router initially. Then the error “Sorry, you have been blocked”, also was showing. At the time I thought it was because my router send some sort of signal to Cloudflare to have it blocked. But that’s not the case because after discovering that it was being blocked when pointing “domain1” to my local container, it gave me the same error. Then I tried another domain “domain2” to point to my router and that did work.

So long story short, “domain1” is showing “Sorry, you have been blocked” on everything and I don’t know why…

Hopefully someone has a solution, because I really at a loss…

You can search for the RayID you see on the block page here: https://dash.cloudflare.com/?to=/:account/:zone/security/events (select your domain)

This will tell you why you were blocked. How to continue depends on what feature blocked you.