Sometimes requests hanging

Hi,
We have multiple DNS registered and proxied.
Everything works great except for one entry.
Sometimes requests hangs forever. It seems that it works only on specific time intervals.

This started to happened today.
Direct access to the machine is made properly.

We already tried DNS Only, Development Mode, Purge Cache and Disable Apps, Disable Perfomance, Disable Security, Cache Level Bypass for this entry, but nothing works.

These are the response headers, when it works:

  1. cf-cache-status:
    DYNAMIC

  2. cf-ray:
    6769b062995803c2-LIS

  3. content-encoding:
    br

  4. content-type:
    text/html; charset=utf-8

  5. date:
    Thu, 29 Jul 2021 22:12:29 GMT

  6. expect-ct:
    max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct

  7. nel:
    {“report_to”:“cf-nel”,“max_age”:604800}

  8. report-to:
    {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report/v3?s=KYih9HCnTqaeNxB6WwkSagmBQauOf734RZbs6grkjwQt5WULvRG%2FeaE2fWiMfwWLV2WAGaJbRXmW7rdu2ctWeMKVbKr3y2cD5xUXzeTsOhB%2FaY60rzcbXWFFtK6F5l8Cng8heC0AVGRVOdFdzHlJAB0dru4NV6UzJssO"}],“group”:“cf-nel”,"max_age”:604800}

  9. server:
    cloudflare

  10. x-powered-by:
    Express

If you tried this (and waited five minutes to take effect), then it’s a server issue. DNS Only means Cloudflare just publishes the IP address for direct connections to your server.

At some point, a :orange: Proxied hostname will return a Cloudflare timeout error. What are you seeing?

Hi,
Thank you for getting in.

But, how can be explained that if I go to the machine via IP address, everything works normally? :confused:

Requests which don’t work reach timeout of 1 min and then a 503 Service Unavailable error is dispatched.

Edit:
I believe we got 3 use-cases here:
1 - Requests work normally
2 - Requests take about 30 secs to finish
3 - Requests timeout after 1 min. Sometimes with 504 Gateway Timeout Error and other times 503 Service Unavailable

Nevermind. We got it working now. It was a docker compose service conflicts

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.