Sometimes my domain and subdomain do not work

Hi,

I have a problem that sometimes my domain and subdomain do not work. When I say sometimes I mean that an hour ago they worked fine, but now they do not, and It changed over the day a few times.
When they do not work, I have this error message:
DNS_PROBE_FINISHED_NXDOMAIN

I have searched a solution for this and saw that the problem might be in the way I configured the DNS records in Cloudflare.

screenshot attachment of my DNS records in Cloudflare:

Other than the DNS records, I have set the following settings:

  • I have activated DENSEC and inserted all the DS records in the correct place at the domain registrar, and Cloudflare noted that the connection is successful.
  • Changed my SSL/TLS mode to Full (strict).
  • I have switched “Always Use HTTPS” to ON.
  • I have created an origin certificate that covers the relevant hosts, and installed it properly in cPanel.

When I runned a diagnostic with Cloudflare Diagnostic Center, I got these errors:

Check the HTTPS status:
Error: fail
Description: No, your request failed with a response status of 400 or above.

Check the site for mixed content:
Error: response_non_200
Description: The site’s web server responded with a status code that isn’t 200 (OK).

Thank you for your help :pray:

Yes, it does return a 404 right now

image

However, I am afraid that’s straight from your server.

$ curl -I https://adigolan.co.il --connect-to ::X.X.X.212
HTTP/2 404

Best to contact your host here.

Thank you again Sandro.

As for the 404, it’s fine, there is nothing installed on this domain. It’s my fault, I should have made it clear.
Getting to the 404 page actually means it’s working now, but again, it can change in a matter of hours.

Anyway, the problem is that sometimes it doesn’t even get to the 404 page. It’s just showing me a Chrome error page, with that error code:
DNS_PROBE_FINISHED_NXDOMAIN

Are the DNS records setted up correctly?

From a DNS point of view, it seems to be set up all right.

I’d assume this will be an issue with your local resolver. Maybe try switching to another resolver whenever you experience the issue. sitemeer.com/#adigolan.co.il should also tell you whether this is a general issue.

This is assuming, of course, there are no changes whenever you have the issue.

I am sorry, what do you mean by “local resolver”? I have tried to find more about it on my own, but it seems to be too complicated for me.

Who can I ask for help to resolve this issue? is it my host or domain registrar? or is it purely related to Cloudflare?

Your local resolver would be the resolver configured on your machine.

This is unlikely to be a Cloudflare issue, most likely a local issue, maybe with your ISP.

Whenever you experience the issue, the following two commands should give you more details on what the issue is.

nslookup adigolan.co.il
nslookup adigolan.co.il 1.1.1.1

It does seem to be a local issue, I will check if this is the case when the problem occur again.

Thank you for your help Sandro.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.