Something WEIRD with my domain. Maybe a redirect loop?

Had a similar problem. Look for redirects in the cpanel as well as htaccess file, and/or index file, not to mention any CF Rules doing the same thing

Thanks for your help so far.
Here’s an update.

Contacted Siteground tech support again.

  1. Tested and confirmed the problem on different browsers (Firefox, Chrome, Edge) both normal and incognito/private mode. Problem still occurs with url : https://soilworx.ca (no “www”).
  2. Cleared Dynamic Cache on SG, and Purged Everything on Cloudflare.
  3. Retested on different browsers, everything worked OK.
  4. Several hours later, tested again and same problem is back.
  5. Contacted SG again, and they added this rule to htaccess file to disable the cache on the host end:
    Header set Cache-Control “private”
  6. Cleared and purged caches again, and retested, and everything working OK
  7. Several hours later, problem came back

SG said that it appears it is a caching issue, however if the problem persists that it must be a conflict on Cloudflare’s end because the caching on host end is now disabled.

I am a newb to this, so I am just trying to make sense of it all. From what I can see, I don’t know if it is a cache issue or if there is some redirect loop, but again I have no idea on how to check this.

As of 9:55am Mountain Time, the problem still persists.

Hello Support, I have been trying to get help through the community for this, as well as through topics and other host tech support.

I have also tried several times to contact support at Cloudflare and you guys just keep ignoring me.
{redacted} Ticket number 2334386

I see duplicate tickets about a billing question that my colleague Christine explained was due to deactivation/activation resulting in the charge; that charge has been credited.

WRT the redirect that you are experiencing with siteground, the post from @fritex mentioned that you need to contact siteground and ask them to disable their new firewall which blocks requests. Did you do that? If they did not understand, ask them about

Finally wrt 2334386 that is marked solved. The ticket was closed as the contact to Support was done from an account that is not the site owner, your email address is not listed as the owner of any Cloudflare account. For the security and privacy of our users, we can only work with the account holder directly and explains what to do in order to contact from the proper account.

1 Like

I was able to capture a few requests.

Yes, I can now see it’s cached by Cloudflare. You’re using APO. You’re kind of stuck here.

APO is made to cache responses for pages. But if SG modifies your page to include a Redirect header, Cloudflare is going to cache that.

You have two options:

  1. Get Siteground to stop using that CAPTCHA system for your site.
  2. Disable APO.
2 Likes

2 posts were split to a new topic: Reporting issue from account owner…issues