Something WEIRD with my domain. Maybe a redirect loop?

Hi all
My website seems to be in some sort of redirect loop or something weird. I’ve made a video screenshot here: Please have a look and let me know.

Thanks

Have you tried using a different Web browser? Or clearing your Web browser cache?

  • you are using Cache Everything as far as I see from HTTP headers HIT for HTML webpage as well as some origin cache defined by x-cache HTTP header

I cannot replicate this at my end, different web browsers.

Non-www and www works fine, no redirection loop (only as it should be, one for non-www to www).

HTTP to HTTPS works fine too.

1 Like

Trying right now…

If you open up your browser’s Dev Tools (F12 in Chrome) to the Network tab, you can usually see what’s happening.

Firefox… https://soilworx.ca - same issue. Stuck in some sort of redirection loop

Able to replicate. I’m pretty sure this is coming from the origin:

<html><meta http-equiv="refresh" content="0;/.well-known/captcha/"></meta></head></html>

1 Like

Okay, my bad.

I had HTTPS-only enabled and extension for adblock.

I can replicate this on non-www HTTPS - blank page, few times “redirected”.

This was HTTPS for me.

Thanks @sdayman… I;m a total newb, so what should I do now? I just recently switched over the cloudflare APO and now this starts happening…

You can try asking your host. They may have some sort of CAPTCHA system built in that’s triggering for some reason.

1 Like

SiteGround maybe?

@user15238 See this one here:

The same code what @sdayman pointed out :

Also here:

From SiteGround:

1 Like

Thanks guys… I’ll get on it now. If you have any other suggestions please leave them here. THX!

1 Like

I tried flushing the cache on both SG side as well as Cloudflare side… still no resolution

Have you written to SiteGround support to check if this is enabled for your site and to disable it, so you could troubleshoot further?:

The only resolution is to ask SiteGround to disable this feature for your site.

This is happening because your AJAX calling is being blocked by SiteGround to show a Captcha (which obviously you cannot fill in an AJAX call).

I would suggest to Purge Everything - as far as you are also using APO too.

You really need to ask your host about this. They should recognize the CAPTCHA URL and advise you as to proper settings for it. Make sure they’re aware you’re using this on your domain through Cloudflare.

1 Like

Could you try it again? I think we may have fixed it. Had to purge caches on both sides

It didn’t loop in my very limited testing, so I hope that fixed it.

1 Like

After a cache purge on both Cloudflare and Siteground (dynamic cache), it appeared to fix the problem temporarily. I could get it to work in incognito mode, and on other browsers (Edge and Firefox). However, I tested it again this morning and we are back to square one.

I’ve been in contact with SG, and the only thing they could recommend was the cache purge (last night).

Please HELP!!

Here’s a video screenshot:

I’m afraid that Cloudflare is not the source of this redirect.

That’s not a glowing endorsement of their level of effort.

1 Like

https://support.cloudflare.com/hc/en-us/articles/115000219871-Troubleshooting-redirect-loop-errors-