Some times and on some computers can't access my website without www in front

Hi. I have set up my custom domain with kajabi through Cloudflare - it has worked well for years. I have the rules set up in page rules as all the help here has outlined.

What I don’t understand is why on some computers or intermittently when i Type in my domain withOUT www - I get the message “This site can’t be reached” - DNS_PROBE_FINISHED_NXDOMAIN

Thank you in advance for your insight!

Greetings,

I am sorry to hear you are experiencing an issue with your domain.

Regarding above stated error, kindly may I suggest looking into below article for more information about why this error happens and how to trobleshoot it:

Was it working over secured HTTPS connection?
May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

May I ask what options do they contain?

May I ask have you checked under the DNS tab at Cloudflare Dashboard for your domain name if there is an existing A carmeldarienzo.com or maybe a CNAME carmeldarienzo.com hostname?

Can you share your domain name here?

I am really grateful for your response.
The domain is carmeldarienzo.com
Let me go through and answer your questions if i can
thank you very much

I am not sure how to answer “was it working over secured HTTPS connection”
IT is checked as FULL

I checked using online tool and a DIG command, and unveortunately I cannot found any of the A carmeldarienzo.com or a CNAME carmeldarienzo.com record configured.

You can add the missing @ (also carmeldarienzo.com) using below tutorial:

If so, redirect any request from carmeldarienzo.com to www.carmeldarienzo.com using a Page Rule and tutorial from below (good for the SEO):

Isn’t this the Cname configured?

WWW yes it is, but not the carmeldarienzo.com alone from what I see?

I am sorry, my bad as I misread this at start → “without www” it does not work, and with www it works, and I written the steps vice-versa for missing www hostname instead of the missing carmeldarienzo.com.

May I ask, have you got any A or CNAME with carmeldarienzo.com at the DNS tab for your domain name?

I really appreciate your help. Truth be told this is all a bit baffling to me, but I will follow your directions and really appreciate your help. The page rules are in. and again, sometimes it works, sometimes it doesn’t . So strange.

no A record, just the CNAME one I posted the picture of

I think you nailed it.
I just noticed that it says to do what you are saying under the DNS page

Kindly, the steps from my above post would be:

  1. Navigate to the DNS tab

  2. Add another DNS entry as CNAME for @ (this is the same as your root domain carmeldarienzo.com) that looks like the www one and make sure it’s proxied and set to :orange:.

  3. After this, navigate to the Page Rules tab and create one to:

Match first input field to the carmeldarienzo.com/*
and add a Setting for Forwarding URL (301)
enter the https://www.carmeldarienzo.com/$1 in the input field

In picture, should look like below:

ok… will do!

1 Like

I will work on this and report back…
thank you very much

1 Like

Yes, I followed your instructions
in the DNS I added the @ CNAME as instructed and got a message “Because CNAME records are not allowed at the zone apex (RFC 1034), CNAME flattening will be applied to this record.”

Then checked my page rules
the first one is www.carmeldarienzo and the second one is carmeldarienzo
made sure everything was as you instructed - went back to the original computer that was not accessing the site and now it works!

1 Like

I can confirm it’s already working on my end and I do see CNAME when I check for it using online tool and DIG command on my PC device :slight_smile:

;QUESTION
carmeldarienzo.com. IN A
;ANSWER
carmeldarienzo.com. 300 IN A 188.114.96.2
carmeldarienzo.com. 300 IN A 188.114.97.2

301 redirect from non-www to www works too :wink:

https://carmeldarienzo.com
**301 Moved Permanently**
https://www.carmeldarienzo.com/
**200 OK**

Yes, true.

It might take few minutes or an hour due to the DNS propagation time around the world, but from now on that’s working :wink:

I am SO Grateful. You are a genius and a generous one of your time.
I will pay your kindness forward. Thank you again.

1 Like

I am glad you have resolved it and I am happy to assist you with it :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.