Some resources/assets not loading from some CDN locations

Hi,

I’ve noticed that some assets/resources, like images, don’t load from certain Cloudflare CDN locations. I am in HK and everything for me loads from the Singapore location.

So, for example, this image does not load for me: https://droneandslr.com/wp-content/uploads/2019/11/sydney-australia-53.jpg


The rest of the website, and everything else loads just fine.

But if I use a VPN, and connect to the US, the image (and everything else) loads perfectly fine.

I’ve been facing this issue for a couple of weeks now and trying to sort it out with my web hosting company (Stablehost). Usually, it’s an issue of IP whitelisting, but this time we’ve whitelisted every IP possible and still this issue persists. This issue causes my pages to not load, or take over 20 seconds to load.

Can someone help me get to the root cause of this issue and solve it?

Thank you!

Hmm, it VPN works & works for me in US.

The 522 #CommunityTip suggests if this is happening only in certain locations that it may be an issue with whitelisting the cf ips. Are you still encountering this issue?

Nice to meet you.

Is Cache Everything and Edge Cache TTL set in Cloudflare Page Rule setting?

For example, a setting like this:

If the URL matches:

Then the settings are:
Cache Level: Cache Everything
Edge Cache TTL: a day

I previously set it to Cache Everything, but forgot to set Edge Cache TTL, so it was not cached at all in CloudFlare.

When I looked at the image in detail, there was cache-control: private, max-age = 2592000 in the header, and because it was private, it was cf-cache-status: BYPASS and it was not cached. If your origin server has the Cache-Control directive set to private, you may need to unset it first.

Please verify that it is cached by Cache Everything above.

1 Like

Thank you for taking the time to respond. I did as you said and still facing the same issue. I also purged all cache too just for good measure.
Here are what my page rules now look like:


Do I you think it’s an issue with my origin server? Because it’s loading everything except for a few assets such as images.
Thanks again for your time, appreciate it!

We’ve whitelisted all CF ips and still encountering this issue. Is there anyway for me to see the exact CF IP from which this image is being requested?

Hello.

When setting Page Rules, it is effective in order from the top, so it is better to move the settings including wp-admin to the top and second.

My site is set up like this.

This site is also set up like this.

I don’t know if it has any effect, but you can change the order by clicking the arrow on the left side of the number next to 1, 2, 3, 4 so change it to 4, 3, 2, 1 from the top please try.

Postscript

I don’t think there is such a mistake, but please check if the Proxy status of the domain is Proxied with an orange cloud in the DNS setting of Cloudflare, just in case.

Also, in the domain registrar’s management screen that you obtained yourself, also check that the name server of the droneandslr.com domain does not include any other name server than the two specified by Cloudflare.

@devesh

As a result of actually measuring it with a server in Singapore with WebPageTest, it was confirmed that the content was cached normally.

〇Test results
https://www.webpagetest.org/result/200112_7K_4faf62afc268dfe33666aab18194aaca/

https://scontent.cdninstagram.com/

It looks like this image is taking a long time to display as Instagram photos are not cached.

Thank you so much! I’m not sure how it happened, but just making those changes that you recommended clearly made a difference. The image is now loading, even if it’s taking some additional time.
Thanks again for all your help :slight_smile:

This topic was automatically closed after 30 days. New replies are no longer allowed.