Some images returned 522 errors


Hello, some time ago, when I tried to check a post that was published, I found some images that could not be opened and returned a 522 error.

I think this happened because the image was deleted, but when I checked on my hosting site. The image is still there and can still be downloaded.

Are there some Cloudflare settings that could cause this to happen?
This is my site url: https://www.monitorteknologi.com/

That URL generally loads fine right now

sitemeer.com/#https://www.monitorteknologi.com/wp-content/uploads/2020/02/Windows-Recovery-Reset.jpg

The error means Cloudflare could not connect to your server. It could be there was some temporary issue with your server about an hour ago when you tried it.

Community Tip - Fixing Error 522: Connection timed out has more on that.

But strangely, this only happens to a few images

Can you provide a link where it is reproducible?

I have deleted and replaced the problem image, all that’s left is this:

https://www.monitorteknologi.com/wp-content/uploads/2020/02/Meningkatkan-Keamanan-Instalasi-MariaDB.jpg
https://www.monitorteknologi.com/wp-content/uploads/2020/02/Meningkatkan-Keamanan-Instalasi-MariaDB.jpg

These two URLs are identical and it loads fine too, well it shows a 404 but it loads

sitemeer.com/#https://www.monitorteknologi.com/wp-content/uploads/2020/02/Meningkatkan-Keamanan-Instalasi-MariaDB.jpg

So what’s the problem and why this can happen on my site.

There probably is some issue with your server and it does not respond. That is all covered by what I wrote earlier.

Yes, if that’s the problem with my site’s server, why does it only occur with a few images

Possibly because of load. You probably best pause Cloudflare for now and have all requests go directly to your server and you monitor it.

Great idea, maybe i should do it at midnight

The article also has more debugging info.