Some error with "Automatically Starting Argo Tunnel"


#1

when I run cloudflared service install, It tell me : INFO[0000] Using Sysv .

What’s happend?
TIM%E6%88%AA%E5%9B%BE20190103115008


#2

anyone can help me?


#3

I cannot find any method to solve it.


#4

So what should I do to use automatic start? Anyeone help me? Please!


#5

It says so and it doesn’t automatically start when the system starts?

I personally don’t have the $$$ to test cloudflared, but, as a Linux guy - I don’t see an error in this message. INFO usually means INFOrmational, a.k.a. “FYI”, and not an ERROR.

And Sysv is probably System V Init, the legacy init system that has been used for many years in Unix and Linux (in the past few years, most Linux distributions jumped ship in favor of systemd which offers many more capabilities (and performance) comparing to SysV init (though many people criticize it for some reasons…).

So, is there an actual issue?


#7

Thanks your reply.
You are right it not error. but after I run this, just show this info not anything happend.
It probably not succes


#8

How do you know nothing happens?

Does it not automatically start when the system boots? (have you rebooted to test?)

If your system is Sysv init based, then there should be a symlink to the service in /etc/rc3.d or /etc/rc5.d (depending on your default runlevel set in /etc/inittab). On some systems the “chkconfig” command might show you this information in tabular format.


#10

我似乎明白了一些。

当我运行“cloudflared tunnel --hostname [hostname] http:// localhost:80 ”时,它运行良好。
我可以访问我的网站,但是当我按CTRL + C它不起作用。所以,如果我想使用argo,我必须保留它,不能做任何事情?
如下图:


#11

I understand what you’re trying to do, and I understand what a manual startup does.

Unfortunately I think my question to you was not answered. You said: “it probably not succes”. I answered: “Measuring success of automatic startup at boot - requires rebooting your system - and then checking if it starts up automatically at boot”.

Did you, or did you not, reboot the system, after you’ve ran the command for automatic start up? If you did - did you check the output of “ps aux” to see that the service does not appear there (and then can say that "it didn’t succeed) - or - you never rebooted - and you think it didn’t succeed, without any justification? (no error message was emitted…)


#12

Yes, I don’t want to start manually. I want to start automatically and my command line can do other things.

When I restarted the server, I visited my website unsuccessfully. I had to start it manually , so I don’t know where I had a problem.

I’m not familiar with argo, maybe the description is a little unclear, so sorry.


#13

I see. Thanks for confirming now that you’ve rebooted since you asked for an automatic startup.

I will be guessing here, based on how you manually start the tunnel.

When you start the tunnel, you explicitly specified the hostname and URL. There should have been a process by which you’ve entered those details, that were supposed to be recorded in your ~/.cloudflared directory and upon invoking the installation command you began this thread with, be copied to /etc/cloudflared directory. So I would check for configuration files there, and verify that they contain the same details you pass when you manually start the tunnel.

Then, you could try to run the service manually (as a service, not the manual way you tried above). I have no knowledge of your OS, so I’ll be guessing here that probably the command service cloudflared start is the right one to attempt to do that. This is similar to what happens when the OS tries to start the service at boot time. Of course, you will want to do that when your manual tunnel has been Ctrl+C’d first. And you can see if that returns any error. Either on the screen when you invoke this command, or by viewing the log file at /var/log/messages (or on some systems, /var/log/syslog ?)


#14

By the way… it sounds strange that when argo tunnel is down, your site is down as well. I would expect Cloudflare to revert to normal origin poll (assuming, of course, you have it configured correctly in the DNS settings…). But again I’m not personally using Argo myself due to the cost. So that’s just me wearing my Engineer hat :slight_smile:


#15

Thank you for your careful reply.
I probably know how to do it.

I start argo, it will automatically add DNS settings.

Can I add your facebook or other ?.

:slight_smile:


#16

I don’t use social media, sorry.

I also don’t provide support over personal means. Questions are rarely unique, and if I answer/analyze in public, other people with similar issues can benefit from that as well.


#17

That’s Ok .
Thank you very much!


#18

No Problem :slight_smile: