Some e-mails from my server go to spam on external providers (eg. GMail)

We’ve been getting complaints that are our e-mails are going to spam lately. I’ve done a search on blacklists and we’re not listed anywhere. I also have SPF, DKIM records. I just added a DMARC record to hopefully help the situation. Other than the missing DMARC record, everything seems to be configured correctly.

DNS records look like:

	Server IP: 123.45.67.89
	Domain: example.com
	Mail Server: mail.example.com, on the same server (123.45.67.89)

	A record: www -> 123.45.67.89 -> Cloudflare proxied
	A record: mail -> 123.45.67.89 -> DNS only
	MX record: example.com -> mail.example.com -> DNS only
	PTR records: none

E-mail addresses are similar to:

	[email protected].com

The nslookup results are as follows:

	> nslookup example.com

		Non-authoritative answer:
		Name:   example.com
		Address: 104.26.6.211
		etc...
		(several Cloudflare IP addresses)

	> nslookup mail.example.com

		Non-authoritative answer:
		Name:   mail.example.com
		Address: 123.45.67.89

	> nslookup 123.45.67.89

		89.67.45.123.in-addr.arpa     name = example.com.

		Authoritative answers can be found from:

Could the problem be because the reverse IP address does not point to mail.example.com but example.com? I would think a mail server would fallback to example.com if mail.example.com fails.

Any tips from experts?

Gmail and Microsoft are pretty picky about reverse DNS, so this wouldn’t surprise me at all.

Not nearly as much as you might think.

That is highly unlikely.

I recommend you post a topic on the dmarcian forum where email delivery and authentication is the sole focus. Short of publishing any relevant DNS records that you deem appropriate, Cloudflare has no involvement in your outbound mailflow.

True, but I posted just in case this might have been some issue I was overlooking due to a reverse IP search pointing to Cloudflare and maybe it was something that could have been solved in the DNS settings.

Today I received my first DMARC e-mail from Google and it appears that SPF is failing, so presumably that’s the issue.

Potentially case closed :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.