[SOLVED] Unable to uninstall app 'Offline' - Unauthorized. This page can be viewed by Authors of resource only

apps
using_apps

#1

Hi,
I’m trying to uninstall an app I no longer need from my domain: Offline.
When clicking the ‘Edit Install’ button I’m getting an ‘Unauthorized - This page can be viewed by Authors of resource only’ error. The ‘Home’ button from this error gives another misconfigured ‘anti_iframe’ error.
Screenshots attached.

I opened a support ticket already but figured the community might have an idea on how to solve this.

Thanks for the help!


#2

Seems like you’re trying to access a shortcut/link to a different account. Go here and try again https://dash.cloudflare.com


#3

Thanks for the suggestion but it’s actually where i’m doing it from. I was a bit rough in my blurring.

Although I think what you are suggesting is related to the issue. If I ‘esc’ on the second error and then go back with the browser i’m getting a new error: ‘you’re in the wrong zone to view this install’.

I found that the app is to no longer be available on the “appstore”. It looks like there is some kind of permission issue that was not correctly applied when the app was removed from availability and I’m no longer able to access/edit/uninstall it even though it is actually installed (loads the js on the site and function as intended).


#4

Hi, sorry you are having issues. You should still be able to edit the install of the app. Could you share with me the name of the zone and the email address you are signed in on?


#5

Are you not able to PM the OP, @victoria? That kind of info surely shouldn’t be posted publicly…

Apologies if you already have :slightly_smiling_face:


#6

Thanks @victoria for the reply! As @domjh pointed out I would rather not post these in public, so I PM’d you.

edit: It seems I cannot PM you so here is the zone ID: 1991a3d3d9fe11287b68c40de14f8050. PM me for my email if necessary.


#7

Only Leaders can start a PM, hence why I suggested @victoria send you one so you can reply with your email.


#8

Quick update to help others with the same problem:
Ticket Support confirmed something was wrong with the app/install and forwarded the issue to the apps team.
I was waiting to hear back from them, which I did not, but when I checked the app again today, it was prompting me for an update.
I did not update, but could access the Edit Install menu and delete the app from there.
I don’t know how exactly this was solved, but opening a ticket was definitely the way to go.
Thanks to everyone who helped.